WordPress Server Compatibillity Checking Tool

Note for System Requirements

This is an script which check WordPress Server Compatibillity for optimal functioning. Without some WordPress will not run. You are suggested to check the WordPress Official Webpage for the latest requirements.

We have created this script for testing a typical Linux-Apache-MySQL-PHP (LAMP) server to run WordPress smoothly. This is however will not work properly for Nginx. The first four (04) points are must to be fulfilled for proper WordPress installation. You can ask at WordPress Forum or contact us in case you are getting too many errors.


PHP Version:7.0.32-0ubuntu0.16.04.1
Apache mod_rewrite:Enabled
GD extension:Installed
Mysql extension:Not Installed
php.ini display_errors:Enabled (Recommended to be disabled)
php.ini memory_limit:128M (Recommended at least 64Mb)
php.ini allow_url_fopen:Enabled
php.ini safe_mode:Disabled
php.ini short_open_tag:Disabled
php.ini file_uploads:Enabled
exiftool:Disabled
zip:Disabled
unzip:Disabled

You are free to continue with the installation even if there are some missing requirements in your server. However, if you want a full experience in your WordPress, it is strongly recommended to have all the requirements installed before proceeding.

If you proceed with any element in red or orange, you can expect random failures in your WordPress Installation and data loss.